
Cutscene Editor Instructions 

The Basics 
The Cutscene Editor allows you to visually create scripted sequences that can be played back in the 

game.  These sequences can range from full cinematic moments like those found in StarCraft II’s Story 

Mode or can be small one-off events. 

What's On Screen 

 

 

1. The Library lists available files and allows you to add them to your current scene. 

2. The Scene List shows all scenes saved in your map and all objects in those scenes.  Selecting 

objects here displays them in the timeline. 

3. All selected objects in the scene are shown in the Timeline Tree.  This is where you can access 

additional properties on an object, such as active animations, conversation lines, and position.  

The timeline tree defines the "what" of your scene. 

4. The Timeline shows all actions that will take place in your scene as well as the current time.  You 

can move and resize blocks to change the timing of your scene and scrub the ruler to change the 

current time.  The timeline defines the "when" of your scene. 

5. There are three Viewports by default.  You can remove some via the Window -> Show Panes 

menu.  Each viewport is a separate view into your scene.  You can select, position, and rotate 

objects in the viewports. 



6. The Property Pane displays all the properties of the current selection.  You can double-click a 

cell to enter edit mode and change any value. 

The Library 

You can add an object by double-clicking the object name in the library 

browser on the top left.  This list contains all objects for the currently 

selected tab (Models, Units, Sounds, Files, or Conversations). 

IF AN OBJECT ISN'T LISTED, CONFIRM THAT YOU HAVE THE CORRECT MAP OR 

DEPENDENCY LOADED. 

You can filter the list by typing in the text area above the list.  All object 

names containing the typed text will show in the list. 

You can toggle between list view and tree view using the button on the 

bottom left. 

Object entries are loaded with all object data -- (in the case of models: 

facial controller, required anims, foley events, etc.).  If you want to add a raw file without associated 

data, you can do so by browsing the Files tab.  This tab lists all loose files that can be added to the scene. 

YOU SHOULD ONLY ADD FILES IF YOU HAVE A SPECIFIC REASON.  IN ALMOST ALL CASES, THE DATA ENTRY IS THE 

BETTER CHOICE. 

Viewports 

The viewports are where you can see the scene at the current time and perform some editing.  There 

are three viewports by default, but you can change the number via Window->Viewports. 

The active viewport is marked with a yellow border.  Commands specific to a viewport (such as changing 

the camera or setting view options) are sent only to the active viewport. 

YOU CAN TOGGLE DEBUG OBJECTS IN A PARTICULAR VIEWPORT VIA RENDER->SHOW HELPERS->SHOW DECORATORS. 

Camera Controls 

We support two different camera control schemes -- Editor and Alternate.  Editor has all the same 

camera controls as the Terrain Editor along with the Free camera controls (middle mouse controls). 

The Free Camera controls are typically best when navigating a cutscene because they allow for any 

camera movement and work well in small scenes.  The Free Camera controls work as follows: 

 Middle Click: Truck along the ground plane 

 Shift-Middle Click: Zoom in and out 

 Alt-Middle Click: Orbit around the target 

 Ctrl-Alt-Middle Click: Mouse look 

 Ctrl-Middle Click: Pan in the camera plane 

 Ctrl-Shift-Middle Click: Field of View 



 Alt-Shift Middle Click: Roll 

 Button 5 Click: Set the target to the mouse position 

YOU CAN ALWAYS CHANGE YOUR CAMERA CONTROLS UNDER FILE->CONFIGURE CONTROLS. 

Scene List 

All scenes in your map or data source will show here along with all objects in each 

scene.  An object is a model, sound, camera, director, or anything else that creates 

something in your scene. 

You can only have one active scene at a time.  To activate a scene, right-click it 

and choose Activate.  You can also add new scenes to your map through the right-

click menu.  

BY DEFAULT, THERE IS ALWAYS A SCENE NAMED (PREVIEWER).  THIS SCENE IS NOT SAVED WITH THE MAP AND IS ONLY USED 

TO PREVIEW ASSETS. 

REMEMBER THAT ALL MODIFICATIONS ARE MADE TO THE CURRENT ACTIVE SCENE.  THIS INCLUDES ACTIONS SUCH 

AS OPEN OR NEW.  THESE ACTIONS WILL OVERWRITE THE EXISTING SCENE UNLESS YOU CHOOSE OTHERWISE AT THE 

PROMPT. 

When you create or load a cutscene, you will be asked if you want to add it to your map.  All cutscenes 

to be played in a given map should be added to that map.  The Cutscene Editor does support loading 

loose .SC2Cutscene files, however, so that you can see what a cutscene looks like without adding it to 

your map.  You can tell the difference between Loose Files, Document Files, or Dependency Files 

(cutscenes located in dependencies to your map) by which folder they belong to in the Scene List. 

ONLY DOCUMENT FILE CUTSCENES ARE SAVED WHEN YOU SAVE YOUR MAP. 

The Scene List is also used to filter what appears in your timeline.  All selected objects in the Scene List 

will appear in the Timeline.  This is very useful for viewing only those objects that you are actively 

working on. 

If you have a lot of cutscene files in your map, use the button “Toggle Active Scene Only” above the 

Scene List to only show the active cutscene. 

Timeline Tree 

All objects selected in the Scene List appear here.  The objects are the parent nodes in the tree, and 

their children define something that the object does or happens to the object.  For example, the actor 

SMX1KerriganDezerged has an Animation Layer child.  The Animation 

Layer child says the actor will play specific animations. 

You can add more children by right-clicking the object and adding an 

appropriate node.  Different node types support different kinds of 

children.  The actor Marine can have a Conversation child while a sound 



object can have a Property Value - Volume child. 

Each node in the tree has its own context menu, allowing you to perform commands on that node.  The 

tree supports multiple-selection. 

YOU CAN COPY AND PASTE NODES.  WHEN YOU PASTE A CHILD NODE, IT CAN ONLY BE PASTED ONTO COMPATIBLE NODE 

TYPES.  FOR EXAMPLE, "ANIMATION LAYER" NODES CAN ONLY BE PASTED ONTO ACTORS WHILE "PROPERTY - POSITION X" 

CAN BE PASTED ONTO ACTORS, CAMERAS, SOUNDS, AND OTHER OBJECTS. 

Timeline 

The timeline displays the current time via the red cursor.  You can click and drag anywhere on the ruler 

to change the current time.  All objects and properties will update in the viewport. 

 

You can play and pause the scene by pressing the Spacebar.  Playback will continue until it reaches the 

end of the scene or an End Scene marker.  It will then loop back to the beginning. 

Scroll the mousewheel to zoom in and out of the timeline and use middle-mouse drag to pan the 

timeline left or right. 

Finally, you can hold Shift and drag to highlight a portion of the timeline.  Selected regions are used for 

specific timeline commands (see below). 

ALWAYS BE AWARE OF YOUR CURRENT TIME.  MANY OPERATIONS DEPEND ON THE CURRENT TIME, SUCH AS 

ADDING ELEMENTS OR AUTOKEY.  THE CUTSCENE EDITOR IS PRIMARILY A TIME EDITOR, SO TIME MATTERS. 

Timeline Elements 

All objects, events, and animated property changes display in the 

timeline.  There are two main types of elements -- events and blocks.  

Events fire a single action at specific time -- camera cuts, actor 

messages, and bookmarks are all examples of events.   

Blocks have duration and maintain during that time, such as animation blocks, object lifetime, and 

dialogue lines. 

All elements can be moved on the timeline by clicking and dragging them.  Blocks can be resized by 

stretching them at either edge.  You can use the arrow keys Left and Right to nudge an item one pixel or 

Ctrl-Left and Ctrl-Right to nudge it five pixels.  The amount of time moved depends on your current 

zoom level. 



Blocks cannot overlap each other.  When positioning a block, you'll be unable to move it past an 

adjacent block.  Events can be moved past each other, but if you place an event on top of another event, 

the two will collapse into a single event. 

YOU CAN COPY AND PASTE ELEMENTS -- ALL PASTING OCCURS AT THE CURRENT TIME AND WILL SPLIT AND OVERWRITE ANY 

EXISTING BLOCKS THAT ARE IN THE WAY. 

Timeline elements can be multi-selected to move or command together.  Click and drag on an empty 

area in the timeline for box selection.  You can also use Shift-Click to select a range of elements on a 

single row or Ctrl-Click to add/remove elements to your current selection. 

Ghost Mode 

If you want to move a block past another one, you can use Ghost Mode (Ctrl+G).  Ghost Mode allows 

you to move or resize a block on top of another one.  When you release the move or resize, any blocks 

in the way will be cut to make room for the new block. 

 

To enter Ghost Mode, click the Ghost Mode toolbar button to the left of the Timeline Tree.  You'll know 

you're in Ghost Mode if you see a silhouette of your block as you're moving it.  Return to Move Mode 

(Ctrl+M) by pressing the Move Mode above Ghost Mode. 

YOU CAN ENTER GHOST MODE FOR A SINGLE ACTION BY HOLDING CTRL-SHIFT WHILE MOVING OR RESIZING A BLOCK.  

Snapping 

When moving timeline elements, they will attempt to snap to other elements in the timeline and the 

current time. 

Locked to End 

Most timeline elements are automatically Locked to End.  This means that as the cutscene's end time 

changes, they automatically update to match it.  An element will have a purple endcap if it is locked to 

end and will stretch as the end time changes. 

 

To unlock an element, right-click it and uncheck Locked to End.  When unlocked, the end time of the 

element only changes when you move it.  In addition, the end time of the entire scene cannot be sooner 

than the last unlocked element. 



AN ELEMENT YOU CANNOT SEE CAN STILL PREVENT THE END TIME FROM SHRINKING.  IF YOU CANNOT MOVE YOUR 

SCENE'S END TIME SOONER, THERE IS AN ELEMENT SOMEWHERE PREVENTING YOU FROM PROCEEDING.  YOU'LL 

HAVE TO FIND THAT ELEMENT AND LOCK OR MOVE IT BEFORE CONTINUING.  WE HOPE TO IMPROVE THIS 

FUNCTIONALITY IN THE FUTURE. 

Playing a Cutscene 

Saving your cutscene generates an .SC2Cutscene file that is saved in your map.  This is simply an XML file 

that describes your cutscene. 

IF YOU KNOW WHAT YOU'RE DOING, YOU CAN HAND-EDIT AN .SC2CUTSCENE FILE, BUT THERE BE DRAGONS DOWN 

THAT PATH!  A MALFORMED XML FILE CANNOT BE LOADED BY THE EDITOR. 

Once saved, that cutscene can be played back in a map by using the Create Cutscene action.  You can 

choose among available cutscenes in the value tab when setting the 

cutscene parameter in your action.  If AutoPlay is enabled, the scene will 

immediately play. 

CUTSCENES MAY HAVE A POSITION OR FACING WHEN PLAYED BACK IF YOU DO NOT WANT 

TO BE AT THEIR DEFAULT POSITION.  USE THE ACTION CREATE CUTSCENE AT POSITION. 

You can use the Last Created Cutscene function to get an ID back to the cutscene.  Additional actions can 

be performed on the cutscene, such as Pause, Set Time, Go To Bookmark, and others.   

While a cutscene is playing, any bookmarks passed in the cutscene will fire an event that can be listened 

for by the Trigger Editor.  This allows the game to respond to cutscenes.  The cutscene will also fire an 

event when it has ended. 

AN EVENT WILL BE FIRED FOR EACH INDIVIDUAL PLAYER WATCHING THE CUTSCENE.  KEEP THIS IN MIND IF YOU INTEND ON 

PERFORMING AN ACTION AFTER ALL PLAYERS PASS A BOOKMARK. 

Objects 
Scene objects include Actors (i.e. models), Cameras, Sounds, and anything else that adds something to 

your cutscene. 

Manipulating 

All objects can be positioned, rotated, and scaled via the Transform Manipulators.  

First, select the object you wish to transform (in the tree or by clicking in the 

viewport).  By default, the Translate Manipulator will appear, allowing you to 

move the object in any direction.  

YOU CAN DISABLE SELECTION HIGHLIGHT VIA RENDER->SHOW HELPERS->SHOW SELECTION 

HIGHLIGHT. 

THE MANIPULATORS ONLY APPEAR WHEN YOUR CUTSCENE IS PAUSED SINCE YOU CANNOT TRANSFORM AN OBJECT 

DURING PLAYBACK. 



Drag along any axis or plane to move the object. 

There are four manipulator modes available, in order: None, Translate, Rotate, and Scale.  The hotkeys 

are Q,W, E, R, which match 3dsMax. 

 

WHEN THE MANIPULATOR MODE IS SET TO NONE, YOU CAN ROTATE THE OBJECT WITH CTRL-CLICK AND MOVE IT WITH 

CTRL-SHIFT-CLICK. 

YOU CAN ENABLE GRID SNAPPING VIA EDIT->GRID SNAP... 

Eye vs. Target Manipulation 

Certain objects, such as Cameras and Spot Lights allow you to separately manipulate the eye or target.  

You can set the Manipulator Mode with the Edit menu or with the toolbar buttons below: 

 

Normal Mode is the default behavior, and it moves the Eye and Target together when translating.  Eye 

Mode allows you to move only the eye whereas Target Mode allows you to move only the target. 

Lifetime 

All objects only exist in the scene for the duration of their lifetime.  This is represented by the timeline 

block that lines up with the object itself. 

 

Try to keep objects in the scene only when necessary to improve performance and reduce clutter in your 

timeline. 

IF YOU CANNOT FIND AN OBJECT WHERE YOU EXPECT IT TO BE IN THE VIEWPORT, CONFIRM THAT IT IS CURRENTLY 

ALIVE AT THAT TIME AND NOT DISABLED OR INVISIBLE. 

Folders 

You can add folders to your cutscene to keep nodes organized by clicking the Add Folder button above 

the Scene List.  Some commands can be performed on a folder to affect all its children.  For example, 

you can set a folder as invisible to mark all its contents as invisible.  

Guide 



You can mark any node as a Guide via the context menu.  Guide nodes are only 

visible in the editor and will not be played back in the game.  This is useful for 

seeing how objects line up with models outside of the cutscene. 

GUIDES ARE COMMONLY USED FOR SETS.  IF YOUR SET PIECE ALWAYS EXISTS ON YOUR MAP, YOU DON’T WANT TO CREATE A 

NEW ONE FOR YOUR CUTSCENE, HOWEVER, YOU MAY WANT TO SEE WHAT YOUR CUTSCENE LOOKS LIKE WITH THE SET IN 

PLACE.  YOU CAN MARK THE SET AS A GUIDE TO SEE IT IN THE EDITOR WITHOUT HAVING IT PLAY BACK IN-GAME. 

Locking 

Any node can be locked via the right-click menu or Ctrl+T.  A locked node 

cannot be edited or selected in the viewport.  It is usually convenient to lock 

nodes you know you don't want to accidentally edit, such as the set objects or 

conversation timing. 

IF YOU LOCK A FOLDER, ALL NODES INSIDE THAT FOLDER ARE LOCKED. 

Disabling 

You can disable a node by unchecking it in the Timeline Tree.  Disabling means something different 

depending on the node.  A disabled Actor will not exist in your scene.  A disabled Animation Layer will 

not perform its animations.  A disabled Camera will still exist but will not draw its camera model.  

Disabled nodes remain disabled when played back in the game. 

Animation 
Models are animated via Animation Layers.  All models start with one Animation Layer by default, and 

additional layers can be added via the context menu in the timeline (Ctrl-A). 

 

You can add a new animation block via context menu (Alt-A).  You can change the animation by right-

clicking the block and choosing Change Animation (+/-).  You can right-click a block and select Reset 

Animation Duration to set the block to its original duration. 

BY DEFAULT, ANIMATIONS ARE ADDED AT THE CURRENT TIME.  YOU CAN CHANGE THIS BEHAVIOR BY TOGGLING THE 

PREFERENCE ANIMATION->ADD ANIMATIONS TO END. 

ALT-A IS THE UNIVERSAL HOTKEY FOR "ADD AN ELEMENT TO THE TIMELINE".  IT WORKS FOR ANIMATION LAYERS, 

BOOKMARKS, PROPERTY LAYERS, AND MOST OTHER NODES. 

You can have multiple Animation Layers.  When animation blocks overlap in different layers, the highest 

priority animation will play.  This can also be used to layer partial animations (such as Angry Eyes) with 

full body animations. 



WHEN YOU STRETCH AN ANIMATION BLOCK, THAT DOES NOT CAUSE THE ANIMATION TO PLAY FASTER OR SLOWER.  

IT SIMPLY CHANGES THE DURATION THAT THE ANIMATION IS PLAYED.  THE LOOP POINTS OF ANIMATIONS ARE 

DENOTED BY VERTICAL LINES IN THE BLOCKS.  YOU CAN USE THE TIME SCALE PROPERTY TO CHANGE THE SPEED AT 

WHICH AN ANIMATION PLAYS BACK. 

Blending 

By default, animations will blend over 150 ms with the previous animation.  This is marked with the grey 

gradient at the start of their blocks.  The blend time can be modified via the Property Sheet.  Animations 

have both Blend In and Blend Out properties, which modify exactly how they blend into each other. 

 

Start Offset 

By default, animation blocks start the animation at time 0 of the sequence.  This can be changed by 

specifying a start offset. 

M3A Files 

You can add M3A Files to actors.  First, select the actors you want to add M3As to.  Then browse for the 

M3A file in the Files tab in the Library.  Double-click the M3A file to add it to the selected actors.  Any 

new animations added by the M3A will be immediately available. 

M3AS ARE GLOBALLY ADDED TO A MODEL FILE.  THIS MEANS ALL COPIES OF THE SAME MODEL WILL HAVE THE NEW 

ANIMATIONS AVAILABLE. 

Cameras 
You can add Cameras to your scene via Object->Add Node (Alt-X).  This adds a camera that matches the 

view of the active viewport. 

 

You can look through any camera or change that camera to the current view via the camera's context 

menu.  The hotkey V provides fast access to looking through a camera.  Alt-V will set the selected 

camera to your current view.  All cameras also show in the View->Camera menu. 

You can live-edit cameras via the Edit Camera command on the camera's context menu.  When live-

editing a camera, the viewport's border will turn red and you'll see "EDITING!" next to the camera's 



name at the top of the viewport.  While live-editing, any changes made to the viewport will apply to the 

edited camera. 

REMEMBER TO TURN OFF LIVE-EDITING WHEN COMPLETE. 

The Camera Editor (View->Camera Editor) is useful for fine-tuning values or accessing properties that 

aren't available via the viewport, such as Depth of Field.   

 

The Director track is responsible for managing which camera is the current active camera.  See below. 

YOU CAN ENABLE ASPECT RATIO GUIDES UNDER THE VIEW MENU TO HELP FRAME YOUR SCENE. 

Game Camera vs. Target Camera 

There are two types of cameras you can create -- Game or Target Cameras.  The difference between the 

two is their list of properties, and this affects how they animate. 

A Game Camera is the classic camera type, which includes a target position and Yaw, Pitch, Roll, and 

Distance properties to determine the eye position.  When animating, these cameras are better for 

orbital motion, such as spinning around an object. 

A Target Camera specifies two positions -- one for the target and one for the eye.  The direction of the 

eye is locked to the target position.  When animating, these cameras are better for trucks, pans, and 

other linear motion. 

Director 
The Director is a special scene object that manages the cutscene itself.  It is responsible for the current 

active camera, the end of the scene, and any environment changes.  You can add a Director via Object-

>Add Director Node (Alt-D). 



Active Camera 

The most common use of the Director is to set the Active Camera.  You can add an Active Camera Layer 

from the Director's context menu. 

Right-click the Active Camera Layer to add a camera cut.  The Add Camera Cut menu will list all cameras 

currently available -- all camera objects plus all cameras embedded in models.  Select a camera from 

that menu to change the active camera at the current time. 

 

ONCE YOU SET AN ACTIVE CAMERA, THAT WILL OVERRIDE THE CAMERA IN-GAME.  IF YOU DO NOT WANT YOUR 

CUTSCENE TO AFFECT THE GAME CAMERA, DO NOT SET AN ACTIVE CAMERA. 

While a camera is active, the view will follow that camera through all its motions.  When you change to 

another camera, that cut is instant. 

MAKE SURE YOUR CAMERA IS ALIVE FOR THE FULL DURATION THAT IT IS ACTIVE. 

Director Window 

The Director Window is used to show you exactly how your scene will look in-game.  You open the 

Director Window via the View menu.  In the Director window, the camera is locked to the active camera, 

and all debug objects, manipulators, and help text are not visible. 

 

YOU CAN SET A CUSTOM SIZE OR ASPECT RATIO FROM THE DIRECTOR WINDOW’S VIEW MENU.  IF YOU CHANGE THE SIZE OF 

THE VIEWPORT, YOU MAY NEED TO RESIZE THE WINDOW TO SEE THE WHOLE IMAGE. 

Director Camera 

You can look through the eyes of the Director in any viewport by selecting the Director Camera via the 

View->Camera menu or pressing the D hotkey. 



IT IS GOOD PRACTICE TO KEEP ONE OF YOUR ACTIVE  VIEWPORTS SET TO THE DIRECTOR CAMERA SO THAT YOU'RE ALWAYS 

AWARE OF WHAT THE DIRECTOR SEES. 

ACTIVE LIGHT 

The Director can also control the active environment light in the cutscene.  Add an Active Light node by 

right-clicking the Director and choosing Add Active Light.  Like the Active Camera Node, this adds a node 

where you can add elements to cut or blend to different lights. 

The Active Light Node can change the lighting to either a light in data (found in the Lighting Window) or 

an available Environment Light Object in your scene.  To use an existing light found in data, select Use 

Light ID when adding the Active Light Element.  You can then set the Light ID property in the Property 

Sheet.  Otherwise, you can choose an existing light in your scene from the context menu. 

See the Lighting section below for information on adding Environment Light Objects. 

YOU CAN BLEND AN ACTIVE LIGHT FROM THE PREVIOUS LIGHT BY SETTING THE BLEND PROPERTY ON THE ELEMENT. 

Fading 

The Director can cause the scene to fade to and from any color.  Add a Fade Node to the Director via the 

right-click menu.  You can then right-click the Fade Node to add new Fade events.  The Fade Event can 

be moved or resized like any other block, and you can toggle between Fade Out and Fade In by right-

clicking the element.  

 

End Scene Markers 

You can add an End Scene node to the Director for fine control of the end of your scene.  By default, a 

scene will end when all blocks are complete.  You can see that via the vertical dashed line on the ruler. 

 

To end the scene earlier, add an End Scene node to the Director via the Director's context menu.  You 

can then add End Scene Marker events to that node.  When the time advances to that event, the scene 

will end. 

YOU CAN HAVE MULTIPLE END SCENE MARKERS IN YOUR SCENE.  THIS IS USEFUL IF YOU USE BOOKMARKS TO JUMP TO 

DIFFERENT PARTS OF YOUR SCENE.  FOR EXAMPLE, YOUR SCENE MAY HAVE THREE DIFFERENT "SUBSCENES", EACH WITH 

THEIR OWN START BOOKMARK AND END SCENE MARKER.  THE TRIGGER SYSTEM CAN THEN DETERMINE WHICH SUBSCENE TO 

PLAY, JUMP TO THAT BOOKMARK, THEN THE SCENE WILL END WHEN IT HITS THE NEXT END SCENE MARKER. 



Bookmarks 

Bookmarks are generic event markers used to mark a specific time.  There are triggers available to jump 

to a bookmark, and when a bookmark is passed, an event is sent to the trigger system. 

YOU MUST GIVE YOUR BOOKMARK A NAME IN ORDER TO ACCESS IT DIRECTLY.  YOU CAN NAME A BOOKMARK VIA 

THE PROPERTY SHEET (SEE BELOW). 

Bookmarks allow the map designer the ability to control the playback flow or respond to events in the 

cutscene.  The subscene system mentioned above heavily relies on bookmarks.  Below you see how 

each subscene is marked with a Start Bookmark and an End Scene node.  The game can decide which 

subscene to play based on game logic, and only that portion of the cutscene will play. 

 

Bookmarks are also useful for synchronizing game actions.  If you want to hide UI or perform an action 

at a specific point in the cutscene, you can do so by responding to the Cutscene Bookmark Fired event. 

EACH PLAYER THAT PLAYS A CUTSCENE WILL FIRE AN EVENT.  KEEP THIS IN MIND WHEN RESPONDING TO THE 

BOOKMARKS. 

YOU CAN USE THE COMMANDS JUMP TO NEXT BOOKMARK (SHIFT+PG UP) AND JUMP TO PREVIOUS BOOKMARK 

(SHIFT+PG DOWN) TO SET THE CURSOR TO THE NEXT/PREVIOUS BOOKMARKS. 

Master Sound 

The Master Sound node allows you to specify the master soundtrack of a cutscene.  The master sound 

track forces the cutscene to stay synchronized to the sound as it plays. 

Properties 
All objects, nodes, layers, and elements are made up of a set of properties.  Many properties, such as 

position or start time, can be manipulated graphically (via the manipulator or timeline).  However, all 

properties can be viewed and edited via the Property Sheet. 

The Properties Pane is visible by default on the right side of the screen.  If you’d rather see it as a 

window, you can select Properties Window from the Window menu. 

The Property Sheet always lists the values for the currently selected node or element. 

THE NODE AND ELEMENT OF AN OBJECT ARE TWO SEPARATE ENTITIES.  THE NODE CONTAINS PROPERTIES FOR 

"WHAT" THE OBJECT IS WHILE THE ELEMENT CONTAINS PROPERTIES FOR "WHEN" THE OBJECT IS. 

MANY PROPERTIES HAVE FRIENDLY VALUES, SUCH AS "ON" OR "OFF".  YOU CAN TYPE THE FRIENDLY VALUE OR THE 

UNDERLYING NUMBER (0 OR 1, IN THIS CASE) TO SET THE VALUE. 



Property Value Layers 

Property Value Layers allow you to change property values over time.  To add a Property Value Layer, 

right-click an object and select the property from the Property Value Layer submenu.  Almost all 

properties can be animated with Property Value Layers. 

A Property Value Layer controls that property's value over time.  You can add value keys to change to 

another value. 

Once a Property Value Layer is added, any changes to that property are sent to the current key in the 

layer.  

You can right-click a Property Value element to change its curve type.  This will affect how the property 

blends from one value to another. 

Auto Key 

Auto Key allows you to automatically add layers and keys to an object any time you make a change.  To 

enable Auto Key, toggle the Auto Key button just to the left of the timeline ruler.  A large red border will 

be visible around the active viewport to indicate that you are in Auto Key mode. 

 

When Auto Key is on, any change to a property will automatically add a new Property Value Layer if one 

doesn't exist and add a new key at the current time.  If the current time is very close to an existing key, it 

will modify that key instead. 

BE AWARE OF WHEN AUTOKEY IS ENABLED!  WHILE IT IS ON, ALL CHANGES TO A PROPERTY WILL ADD A KEY.  BE 

SURE TO TURN AUTOKEY OFF WHEN YOU ARE FINISHED. 

Curve Editor 
By default, all value changes occur over a linear curve.  The Curve Editor gives you full control of how 

one value changes to another.  You can open the Curve Editor via the toolbar. 

The Curve Editor displays all the keys for the selected Property Value Layers.  Each control point in the 

curve editor represents the time and value of the corresponding key.  You can move these control points 

in the curve editor to directly change their time and value.  You can also set the values via the text boxes 

on the top. 

IF YOU DON'T SEE YOUR CURVE, MAKE SURE IT IS SELECTED IN THE TIMELINE TREE. 



You can add new points by clicking the Create Mode button in the toolbar.  You can also Shift-Click and 

drag a key to duplicate it. 

 

NOTICE AS YOU CHANGE VALUES IN THE CURVE EDITOR THAT THEY LIVE-EDIT THE VALUES BOTH IN THE VIEWPORT AND ON 

THE TIMELINE.  YOU CAN PERFORM VERY FINE CONTROL IN THE CURVE EDITOR. 

View Controls 

Use the middle mouse button to drag the view and the mouse wheel to zoom in and out.  Change to 

Custom View mode to draw a box specifying the area you want to view. 

IF YOU LOSE YOUR PLACE, CLICK BOTH ZOOM EXTENTS X AND ZOOM EXTENTS Y TO ZOOM TO FIT. 

You can view the tangents and values of selected points by enabling those options in the Toolbar. 

Curve Types 

Each control point has a curve type for both in and out.  You can change these types by selecting the 

control point and pressing the Smooth, Linear, Slow, Step, or Custom buttons.  The value will be set for 

either In, Both, or Out, depending on which mode you're in. 

When you select a Custom curve type, tangent controllers are displayed.  You can move the tangent 

controller to set exactly how the value curves in or out of the control point. 

Lights 
There are three kinds of lights you can add and animate in your scene: Omni Lights, Spot Lights, and 

Environment Lights. 

Omni and Spot Lights 

Omni and Spot Lights are light objects you can add to your scene via the Object->Add Node menu.  An 

Omni Light will light in all directions (like a lightbulb) whereas a Spot Light will light a cone in a specific 

direction (like a flashlight). 



Lights, like any other object, have a position and rotation, and they can also be colored.  In addition, 

lights have a number of unique properties: 

AmbientOcclusion 

Enables whether or not this light is affected by Ambient Occlusion (Requires Extreme Shaders) 

AttenuationStart 

This is at what distance the light begins to fade away from maximum brightness.  For Omni Lights (see 

image below), this affects the light radius.  For Spot Lights, this affects the distance from the light source 

to the target. 

Low Attenuation                              High Attenuation 

 

ColorMultiplier 

This is essentially the intensity of the light.  Zero will disable the light, values below 1 are dim, and values 

above 1 are extra bright. 

Low Color Multiply                          High Color Multiply 

 

Falloff 

Spotlights Only. This is the distance at which the spot light is fully dimmed. 

Hotspot 

Spotlights Only.  This is the size of the bright spot in the center of the spot light before it begins to fall 

off. 

 



Small Hotspot                    Hotspot = Falloff                              Large Falloff 

 

Range 

For Omni Lights, it’s the radius the light affects.  For Spotlights, it’s the distance from the light source to 

the target. 

ShadowCasting 

Spotlights Only.  Whether or not a light casts shadows.  This requires Medium lighting or higher. 

Specular 

Whether or not a light causes specular highlights.  (Requires Ultra Lighting). 

SpecularColor 

The color of the specular highlights created by this light.  Only has effect if Specular is 

enabled.  (Requires Ultra Lighting). 

ALL LIGHT PROPERTIES CAN BE ANIMATED, SO HAVE FUN WITH THE LIGHTS! 

Environment Lights 

Environment Lights control the three directional lights in your scene (Key, Fill, and Back) as well as the 

HDR and Colorization options of the scene.  These are the exact same lights you will find in the Lighting 

Window. 

Like cameras, only one Environment Light may be active at a time, so the Director controls this with an 

Active Light Node (See Above). 

You can use an existing light from data, or you can add a new Environment Light Node to your scene via 

the Object->Add Node menu. 

AN ENVIRONMENT LIGHT NODE DOES NOT HAVE AN EFFECT ON THE SCENE UNLESS IT IS ACTIVE. 

Environment Lights are not objects in the scene – they do not have a position or lifetime.  They act like 

Fog in the sense that they just exist.   

Once added, you can edit any of the 80+ properties via the Property Sheet, most of which can be 

animated.  However, the easiest way to edit them is with the Lighting Window.  You can access the 

Lighting Window under the Window->Lighting menu. 



 

With the Lighting Window open, you can select an Environment Node in your cutscene.  That will update 

the Lighting Window and allow you to edit it.  When you are happy with your changes, you can then 

select Data->Set Cutscene Light to send the changes to all selected Environment Lights.  If autokey is 

enabled, the values will be sent as new keys. 

MAKE SURE YOU SAVE YOUR CHANGES FROM THE LIGHTING WINDOW TO YOUR ENVIRONMENT LIGHT NODE BY 

SETTING THE CUTSCENE LIGHT!  ALTHOUGH THE VIEWPORT WILL UPDATE WHILE EDITING THE LIGHT, THE VALUES 

ARE NOT SAVED UNTIL YOU DO SO. 

REMEMBER, WHILE THE LIGHTING WINDOW IS OPEN, THAT CONTROLS THE LIGHTING OF YOUR SCENE.  YOU WILL 

NEED TO CLOSE THE LIGHTING WINDOW IN ORDER FOR YOUR ACTIVE LIGHT NODE TO CONTROL THE SCENE AGAIN.  

ALSO, MAKE SURE YOUR LIGHTING MODE IS SET TO “DEFAULT LIGHTING” UNDER RENDER->LIGHTING. 

Sounds 
Sounds are added through the Sounds tab on the Library.  Adding a sound will add the sound object to 

your scene and the element at the current time. 

Sounds with variations choose a random variation when they are added, but they will always play the 

same variation each time the cutscene is played.  You can change the variation in the Property Sheet. 



Sounds also contain Volume and Pitch properties.  Volume can be animated like any property, but Pitch 

cannot. 

REMEMBER THAT 3D SOUNDS HAVE A POSITION.  YOU CAN MOVE THE POSITION OF A SOUND WITH THE 

MANIPULATOR LIKE ANY OTHER OBJECT.  IF YOU CAN'T HEAR A SOUND, LIKELY YOUR CAMERA IS TOO FAR AWAY 

FROM THE SOUND. 

Text 
Text Nodes allow you to add text to the world.  These text objects have a position, like all objects, but 

they are always facing the camera and have a constant size regardless of how far the camera is.  They 

have all the properties of standard objects, and they can be animated, attached, or placed on a path. 

You can add special dynamic tags to text nodes to auto-replace the text.  Currently the only two are: 

 (frame) - Displays the current frame 

 (time) - Displays the current time 

Case is not sensitive, but the parentheses must be included.   

You can also use any text tags available to set the color, add an image, or do anything else you can 

typically do with text. 

 

Conversations 
Conversation Layers specify dialogue that your characters will speak.  To begin, add a Conversation Layer 

via an actor's Context Menu. 

While a Conversation Layer is selected, all sounds added to your scene will be interpreted as dialogue 

and add a block to that Conversation Layer.  When the block is hit, the sound will play and facial 

animation and subtitles will trigger if found. 

A CONVERSATION LAYER MUST BE SELECTED IN ORDER TO ADD A NEW CONVERSATION BLOCK.  OTHERWISE, THE 

SOUND WILL BE INTERPRETED AS A GENERAL SOUND OBJECT. 

Conversation Driver 

You can add a Conversation Driver node to the Director by adding a Conversation Object from the library 

when the Director is selected.  A Conversation Driver node specifies which region of your cutscene 

belongs to which conversation line. 



To add a line, right-click the Conversation Driver node and select Add Line.  This opens the Conversation 

Import Window (see below). 

When a conversation is set up to drive a cutscene (via the Data Editor), that cutscene is automatically 

played in the game.  The conversation engine in the game will tell the Conversation Driver node to jump 

to the active line as the conversation progresses.  When that line is complete, the conversation engine is 

notified, it selects the next line, then jumps the cutscene to that line. 

YOUR CONVERSATION LINES IN THE CUTSCENE NEED NOT BE IN THE SAME ORDER AS THEY PLAY BACK.  WHEN LINES ARE IN 

THE CORRECT ORDER, HOWEVER, THE CUTSCENE WILL NOT JUMP TO THE NEXT LINE, BUT INSTEAD IT JUST CONTINUES 

PLAYING.  FOR THIS REASON (AND TO AVOID CONFUSION WHEN EDITING), IT'S BEST TO KEEP THEM IN ORDER.  CHANGING 

THE ORDER OF THE LINES IN DATA WILL NOT REQUIRE YOU TO REBUILD YOUR CUTSCENE, THOUGH. 

Import Conversation 

Adding lines to the Conversation Driver will open the 

Conversation Import Window.  This lists all lines in the 

conversation data for the conversation the driver is linked 

to.  Select the lines you want to add then click Import to 

add them to your scene. 

NEW LINES ARE ADDED IN THE ORDER THEY APPEAR IN THE CUTSCENE. 

When adding lines to your driver, the importer will attempt 

to construct the scene for you.  Added lines perform the 

following tasks: 

 Adds the line to the Conversation Driver for the 

duration of the sound asset. 

 If it finds an actor with the appropriate Speaker Tag property set, it adds the conversation block 

and animation for that line. 

 If it finds a camera with the appropriate name, it sets the active camera to that camera for the 

duration of the line. 

 Sets up all linking. 

The created scene should be equivalent to what you would get in the game. This is meant as a starting 

point -- you can then edit the scene in any way. 

BECAUSE CONVERSATIONS ARE SYNCHRONOUS AND CUTSCENES ARE ASYNCHRONOUS, THERE CAN BE A SMALL 

AMOUNT OF LAG DURING CONVERSATION PLAYBACK.  TRY TO AVOID HAVING KEY MOMENTS OCCURRING WITHIN 

THE LAST 100 MS OF A LINE. 

Attachments 
You can attach any object to any other object, including attachments points on models.  To do this, 

right-click the object and select Attach To.  This will list all objects and their attachment points, if any.  



When you attach an object, an element is added to the timeline.  The object is only attached during the 

duration of the element. 

 

You can specify a position and rotation offset on the attachment element.  You can also specify whether 

or not you want to inherit scale and visibility from the host object. 

THE SYSTEM AUTOMATICALLY PREVENTS CIRCULAR ATTACHMENTS.  IF YOU DO NOT SEE A MODEL LISTED, IT IS BECAUSE THE 

MODEL EITHER HAS NO ATTACHMENT POINTS OR IT WOULD CAUSE A CIRCULAR ATTACHMENT.  DO NOT FORCE CIRCULAR 

ATTACHMENTS BY EDITING THE XML FILE – IT’S KIND OF LIKE CROSSING THE STREAMS. 

MODELS THAT ARE ADDED VIA THE FILES TAB DO NOT HAVE ALL MODEL DATA LOADED.  BECAUSE OF THIS, THEY 

ARE FORCED TO INHERIT SCALE AND VISIBILITY FROM THEIR HOST, AND OFFSETS DO NOT FUNCTION. 

Look At 
Look At allows you to have a Story Mode character with the proper data to look toward any object or 

attachment point.  It's useful to cause a character to look in any direction and can also be used to 

simulate head bobbing, nodding, or shaking. 

 

Look At is set up similarly to attachments.  Simply right-click the actor you want to do the looking, 

choose Look At, and choose the target.  While the Look At Element is active, the character's gaze will 

always follow that object.  You can animate the target however you wish, and the looker will follow. 

You can change the type of Look At by right-clicking the Look At element.  Types include the speed at 

which to blend into the Look At and how strongly the character looks in that direction. 



EYE AND HEAD LOOK AT CAN BE SEPARATED TO LOOK AT DIFFERENT OBJECTS, ALLOWING YOU TO PERFORM EYE DARTING OR 

EYE-LEADING. 

Pathing 
You can add a path node via the Object menu.  The path node defines a path that any object can follow. 

 

With the Path Node selected, change your brush mode to Create (the right button below): 

 

In this mode, clicking anywhere in the scene will add a path marker there.  Each path marker defines the 

next point in the path.  You can change the order of path markers via the timeline tree on the bottom 

left. 

If you change to Selection Mode, you can click a Path Marker to select it and move it with the translate 

manipulator. 

After creating your path, you can tell an object to follow the path by adding a Follow Path node to that 

object.  To define when to follow which path, add a Follow Path block.   

 



While the block is active, the object will follow the path.  The movement speed, by default, is 

determined by the current animation.  For example, the Marine will follow the path so long as he’s 

playing a Walk animation.  If he’s playing Stand, he won't progress down the path.  All animation blocks 

have a Movement Speed property.  You can change this value via the Property Sheet. 

You can change the In and Out Tangents of our path markers to modify the shape of the curve. 

Follow Terrain 

By default, objects follow the path exactly as defined.  You can force them to snap to terrain by setting 

the Blend to Terrain property to 1.0.  When that is enabled, the object's height is determined by the 

terrain, not the path.  Follow Terrain is also respected for non-path movement.  That value can be 

anywhere between 0 and 1 to smoothly blend to/from full terrain snapping. 

Always Point Up 

By default, objects rotate as they move up and down a path.  If you want the object to always point up, 

set the property Always Point Up on the Follow Path block. 

Active Shot 
It is often necessary to show or hide objects only when a specific camera is active.  For example, if you 

have custom lighting set up for each camera angle or if an object is in the way of a specific camera, you 

can make it so that these objects automatically show/hide based on the current shot. 

To use this feature, right-click the object that you want to tie to a shot and select “Active For Shot…”.  

You can then check on any camera you want the object to be active for.  You can also select Current 

Active Shot to enable the object for whichever camera is currently active.   

While those cameras are active, the object will be visible.  For all other cameras, the object will be 

invisible.  You’ll also see this in the timeline – the blocks will be grey during shots they are not active for. 

You can copy and paste the active shot setup from one object to another to easily transfer that data to 

other objects. 

Filtering 
You can add a filter to objects so that they are only active under certain conditions.  For example, if you 

want a green light to appear when the player wins or a red light to appear when the player loses, you 

can accomplish this with filtering. 

To setup the example above, add both lights to your scene.  You can then set the filter property on 

those nodes to “red” and “green”.  Normally, both lights will be visible, but if you set a filter via triggers, 

only nodes with filters that match the current filter will be visible.  In this way, when you play back the 

cutscene, you can set the filter (per player) to match the game condition. 

If you want to see what your scene looks like under different filters, you can set the Filter Test property 

on the Director.  That property is not saved – it is only used to preview what your scene will look like 

with a given filter. 



Fog 
You can add and animate fog in the scene by adding a fog node (Object->Add Fog Node).  Once added, 

you can set the properties of fog or animate them like any other object. 

Render To Texture 
Render to Texture allows you to render the view of a camera onto a texture.  This is useful for things 

such as television screens, mirrors, and other similar objects. 

RENDER TO TEXTURE ONLY WORKS WHEN "CAMPAIGN MODE" RENDERING IS ENABLED.  IN THE CUTSCENE EDITOR, 

THIS IS DONE VIA VIEW->CAMPAIGN MODE.  IN THE GAME, YOU NEED TO USE THE TRIGGER "ENABLE STORY 

MODE". 

An RTT Node specifies which camera controls which channel.  There are seven different channels that 

can be controlled, and the material on the art is generally set to a specific channel.  You can change 

which channel the node controls via the context menu. 

 

Once the channel is set, you can add a block for when a camera is bound to that channel.  While that 

block is active, the corresponding camera will render its view onto the node's channel, affecting any 

correctly setup art.  This may require a bit of experimentation when you first start. 

CURRENTLY ONLY CAMERAS FOUND INSIDE MODELS CAN BE USED FOR RTT (I.E. NOT CAMERA NODES).  THERE ARE 

MODELS AVAILABLE THAT ARE NOTHING BUT A SINGLE CAMERA. 

Linking Timeline Elements 
Elements can be linked to one another to maintain a time relationship.  This is useful if you want to keep 

a fixed time distance between elements.  This relationship is maintained even if the asset changes due 

to localization or being changed. 



Adding Links 

To link objects, change the timeline to Linking Mode.  You can then drag the start or end of any element 

to the start or end of another element.  This causes the first element to be locked to the second 

element. 

 

In the example above, if you move or resize the bookmark, both the end scene marker and the 

animation will move to maintain the fixed distance. 

Most importantly, if they were linked to a dialogue line, and that line has a different duration in another 

language, that fixed distance will still be maintained.  You can set up an entire chain of links for a 

complicated scene to make sure all camera cuts, animations, dialogue lines, and other timed events are 

properly maintained when localized durations change. 

Linked objects draw with a special end cap.  To view the linking lines, enable the option under the View 

menu. 

YOU CAN LINK BOTH THE START AND END OF A BLOCK SEPARATELY.  THIS WILL CAUSE THE BLOCK TO STRETCH OR SHRINK 

ACCORDINGLY. 

IT IS GOOD PRACTICE TO HOLD OFF ON COMPLEX LINKING UNTIL THE SCENE IS MOSTLY COMPLETE.  ONCE LINKS ARE 

ESTABLISHED, IT MAY BE DIFFICULT TO MOVE BLOCKS IF IT WOULD CAUSE ANY BLOCK IN THE CHAIN TO OVERLAP 

ANOTHER ONE. 

Removing Links 

You can remove a link by selecting the element and pressing the Remove Link button next to Link Mode. 

Advanced Timeline Functions 
The Timeline offers a number of advanced features for editing.  Most of these features work off the 

selection in the timeline.  You can shift-click on the ruler to select a portion of time.  You can also set the 

In Marker or Out Marker at the current time using hotkeys I and O. 

By itself, the selection doesn't change anything.  If you want to keep the cursor locked inside the 

selection, you can Toggle Loop In Out.  The cursor will then loop back to the start of the selection when 

it reaches the end.  You can also jump to the start or end of your selection with hotkeys Alt+I and Alt+O. 



Splitting Blocks 

Blocks can be split to allow you to move them around in pieces or remove portions of them.  To split a 

block at the selected time, select the block and choose Split Selected Blocks (Ctrl+K).  The block will be 

split along the time cursor (vertical red line). 

 

Split All Blocks (Ctrl+Shift+K), as you'd expect, will split all blocks at the current time.  This includes 

blocks that are not currently visible. 

MOST BLOCK TYPES, SUCH AS ANIMATION AND SOUND BLOCKS, WILL MODIFY THE START OFFSET OF THE SECOND BLOCK SO 

THAT SPLITTING IT HAS NO EFFECT ON THE PLAYBACK OF THE CUTSCENE. 

OBJECT LIFETIME BLOCKS CANNOT BE SPLIT SINCE THERE CANNOT BE MORE THAN ONE BLOCK FOR A GIVEN OBJECT. 

Non-Linear Editing 

You can also use the selection area to add or remove time to your cutscene.  With a time region 

selected, you can Insert Time (=) to add a new block of empty time in that region.  All blocks previously 

in the region are spliced and pushed out to make room for the new area. 

 

Similarly, you can Remove Time (-), which splices all blocks in the selected region, removes them, and 

compresses everything that came after the selection. 

Importing 
You can import objects from another cutscene by right-clicking the source cutscene and choosing 

Import.  Select the objects to import and press the Import Button.  This will add a copy of that object to 

your scene. 

If you want to re-import an object that has changed, check Overwrite.  If that object was previously 

imported, it will be replaced with the new version. 



 

References 

You can also import an object as a reference.  Instead of making a copy of that object, it simply imports a 

reference to the object in the other file.  If that object changes in the source file, it will also change in 

your scene.   

In this way, you could create a cutscene file that is nothing but a library of useful cameras that can be 

used in other files.  If you change the camera in the source file, you won't need to make any changes to 

all the places it's used. 

YOU CANNOT MAKE CHANGES TO A NODE IMPORTED AS REFERENCE. 

Exporting 
You can export your cutscene via the File Menu to create a .SC2Cutscene file.  You can then open it 

again via File->Open Cutscene.  If you want to add it to the current map, select Yes at the prompt.  

Otherwise, it will be considered a loose file and will not be saved with your map.  

Map Import 
You can import the terrain and placed objects of the current open map by clicking the Import Terrain 

button on the toolbar.  This looks at your preferences set under File->Map Import, and imports all the 

checked components of your map. 

You cannot edit the terrain in the Cutscene Editor, and you will need to re-import if you make changes. 



 

Appendix – Property Reference 

Commandable 

Basic type that all nodes and elements derive from. 

ID The unique ID of the node or element. 

Parent ID The ID of the parent node or element 

Reference File The cutscene an imported object is referencing. 

Reference GUID The ID an imported object is referencing. 

Node 

The “what” of a scene.  These are objects and other things that perform an action. 

Enabled Enables or disables the node. 

Filter Allows you to conditionally enable the node based on the current filter. 

Guide When enabled, the node will not be enabled during playback in game. 

Locked The node cannot be modified or selected in the viewport. 

Name The display name of the node. 

Visible The visibility state of the node.  The node is still enabled, but it is not 
rendered. 

Element 

The “when” of a scene.  They dictate when actions take place or objects exist. 

Duration The amount of time this element persists, in milliseconds. 

End Link Distance The distance in time between the end link and its target. 

End Link to Point The location within the element the end is linked to (start or end) 

End Linked to GUID The GUID of the element the end is linked to. 

Start Link Distance The distance in time between the start link and its target. 

Start Link to Point The location within the element the start is linked to (start or end) 

Start Linked to GUID The GUID of the element the end is linked to. 



Start Time The time this element starts 

Object 

Something that exists in the scene, including models, sounds, and cameras. 

Blend to Terrain When set to 1.0, the object will be snapped to the current terrain height.  
The value can be anywhere between 0 and 1 to blend the snapping. 

Finder Tag A tag set so that external actor systems can look up the object’s actor. 

Fog Visibility Determines if the object is visible under Fog of War: 

 Hidden: The object is not visible under Fog of War. 

 Snapshot: A snapshot is taken when the object enters Fog of 
War. 

 Dimmed: The object is dimmed under Fog ofWar. 

 Visibile: The object is fully visible under Fog of War. 

Height Offset A distance to offset the object’s height.  This is similar to the object’s 
Position Z. 

Movesped The speed at which an object will follow a path if “Use Object 
Movespeed” is enabled on a Follow Path Node. 

Position Position X of the object, relative to the cutscene position. 

Rotation Rotation X (pitch) of the object. 

Scale Scale X of the object 

Actor Node 

An animatable model in your scene. 

Actor Alias The alias of an actor to mimic.  When this actor is created, it will look up 
an actor in the world with the set alias.  If it finds one, it will create a new 
actor identically matching that actor and use that in the cutscene instead 
of the one defined. 

Editor Model This is the model to use in the editor only.  It can be useful if you want 
something to look one way in the game and another way in the editor. 

Enable Physics When enabled, the model is used for physics. 

FXA Override Specifies a different FXA Facial Animation file to load on this model. 

Model Link The model data entry to use for this object. 

Model Path The model path to an .m3 file to use for this object. 

Opacity The Opacity of the model.  1.0 means fully opaque and 0.0 means fully 
transparent. 

Shadow Box When enabled, the shadow box of this model is used.  There can only be 
one model with a shadow box enabled in your scene.  The shadow box 
specifies a custom area that shadows are rendered in. 

Speaker Tag The Speaker Tag of a model is used during conversation import.  It must 
match the speaker in a conversation for automatic importing to work. 

Texture Quality An override value for texture quality on this model.  Legal values are 
Default, Low, Medium, High, and Ultra. 

Tint Color A tint color to apply to the model. 

Unit Link (Unsupported) The unit data entry to use for this object. 

Use Anim Movespeed When enabled, animation movement speed is used for following paths.  



When disabled, the object movement speed is used. 

Variation The variation number to use on this model.  Variations are randomly 
chosen when a model is added to a scene, but it can be changed in this 
property. 

Walk Automatically move forward based on animation movement speed. 

Team Color The team color to apply to this model.  Diffuse properties are used for 
standard materials (a marine’s armor) and emissive properties are used 
for glowing materials (a zealot’s blade). 

Animation Layer 

A node containing a list of animation events. 

Animation Element 

An element that determines when and how to play a specific animation. 

Animation The name of the animation to play. 

Animation ID (Read Only) The animation ID of this animation.  You can use this ID to 
refer to this animation in Actor Messages. 

Blend In Time The amount of time to blend into this animation. 

Blend Out Time The amount of time to blend out of this animation. 

Looping (Read Only) Whether or not the animation is a looping animation. 

Movespeed The speed to follow a path or walk while this animation is playing. 

Original Duration (Read Only) The duration of the animation in the asset. 

Original Movement Speed (Read Only) The original value of movement speed in the asset. 

Play Forever When enabled, looping animations continue and non-looping animations 
hold their final pose after the original duration. 

Play Once When enabled, animations are cleared after their original duration. 

Priority (Read Only) The priority of the animation in the anim stack. 

Right-Aligned When enabled, the animation block is aligned to the right such that the 
end of the block corresponds to the end of the animation. 

Start Offset The time within the animation to begin at the start of the element. 

Time Scale A scale to apply to the playback speed of an animation. 

Look At Node 

A node containing a list of Look At elements. 

Look At Element 

An element that directs an actor model to “Look At” another object.  The model must be properly set up 

for this element to take effect. 

Attachment The attachment point the object is looking at. 

Ignore Eyes Do not apply this Look At to the eye bones.  This is useful if you want to 
use separate Look Ats for the head and eyes. 

Target GUID (Read Only) The GUID of the object to look at. 

Type The Look At style type. 



Conversation Node 

A node containing a list of conversation elements. 

Conversation Element 

A single line of dialogue to be spoken by an actor model. 

Conversation Line The Line ID to use for this conversation element. 

Conversation Link The conversation data entry to use for this conversation element.  
Conversation elements can be played by Sound Link or by Conversation 
entry. 

Duration Offset The offset between the original duration and the actual duration.  This is 
used when automatically adjusting scenes due to localization. 

Facial Anim The facial animation entry to play for this line. 

Facial Group The facial animation group the animation exists in. 

Sound Link The sound link to use for this conversation element.  Conversation 
elements can be played by Sound Link or by Conversation entry. 

Start Offset The start time within the sound to begin playing. 

Variation The variation of the sound to play. 

Volume The volume scale to apply to the sound file. 

Follow Path Node 

A node containing a list of Follow Path elements. 

Follow Path Element 

An element that tells an actor model to follow a path in your scene. 

Always Point Up Always orient the object following the path such that it points up as 
opposed to following the slope of the path. 

Path GUID (Read Only) The GUID of the path object to follow. 

Path Rotation Offset A rotation offset to apply when following the path. 

Attachment Node 

A node containing a list of attachment elements. 

Attachment Element 

An element that tells an object to attach to another object.  When attached, the object will follow the 

parent wherever it goes. 

Attachment GUID The object to attach to. 

Attach Point The attachment point to attach to. 

Inherit Scale Automatically inherit the scale of the parent object. 

Inherit Visibility Automatically inherit the visibility of the parent object. 

Offset The amount to offset the position by when attaching. 

Rotation The amount to offset the rotation by when attaching. 

Property Value Node 

A node that controls how a specific property changes over time. 



Property (Read Only) The property this node is controlling. 

Property Value Element 

An element that specifies when a property value should change and how that change occurs over time. 

Value The value to change the property to when this element is passed. 

In Tangent Data The tangent of the in point when curving this element. 

In Tangent Type The curve in style of this element. 

Out Tangent Data The tangent of the out point when curving this element. 

Out Tangent Type The curve out style of this element. 

Sound Node 

A sound object in your scene.  The lifetime of the sound determines when it is played. 

Actor Alias The alias of an actor to mimic.  When this actor is created, it will look up 
an actor in the world with the set alias.  If it finds one, it will create a new 
actor identically matching that actor and use that in the cutscene instead 
of the one defined. 

Model (Read Only) The sound type – 2D, 3D Relative or 3D World. 

Pitch A pitch scale to apply to the sound.  Values higher than 1.0 are high-
pitched and cause the sound to speed up.  Values between 0 and 1 are 
low-pitched cause the sound to slow down. 

Sound Link The sound data entry to use for this sound node. 

Start Offset The starting point within the sound to begin from, in milliseconds. 

Variation The variation number to use on this sound.  Variations are randomly 
chosen when a sound is added to a scene, but it can be changed in this 
property. 

Volume A multiplier on the volume of this sound. 

Camera 

A camera object in your scene.  You can make a camera active through the Director’s Active Camera 

node. 

Depth of Field The amount of blur to apply due to depth of field. 

Distance The distance from the target of the camera to the eye of the camera. 

Eye Position The position of the camera’s eye. 

Falloff End The distance from the start of falloff until depth of field is fully blurred. 

Falloff Start The distance from the focal point until depth of field begins to blur. 

Far Clip The distance at which far away objects are no longer visible. 

Field of Field The angle of the lens. 

Focal Depth The distance at which the camera is focused. 

Height Offset An offset of the camera’s Z height 

Near Clip The distance at which near objects become visible. 

Pitch The vertical angle of the camera. 

Roll The tilt of the camera. 

Shadow Clip The distance at which shadows are no longer visible. 

Target Position The position of the target of the camera. 



Vertical FOV When enabled, measure Field of View as a vertical value. 

Yaw The facing angle of the camera. 

Director Node 

A special node that controls scene-level properties in your cutscene. 

Active Camera Node 

A node containing a list of active camera elements that control when to cut to specific cameras. 

Active Camera Element 

A single camera cut event. 

Camera Index The index of the camera within the camera object to cut to. 

Object ID The ID of the camera object to cut to. 

Active Light Node 

A node containing a list of active light elements that control when to change the main environment 

light. 

Maximum Light Level The maximum graphics quality level at which this node functions.  Allows 
you to specify different lighting depending on graphics options.  Legal 
values are None, Low, Medium, High, and Ultra. 

Minimum Light Level The minimum graphics quality level at which this node functions.  Allows 
you to specify different lighting depending on graphics options.  Legal 
values are None, Low, Medium, High, and Ultra. 

Active Light Element 

A single light change event. 

Blend Time The amount of time to blend into this light change. 

Light GUID The GUID of the Environment Light object to change to.  Active Light 
elements can change to Environment Light Objects or entries in data. 

Light ID The light data entry to change to.  Active Light elements can change to 
Environment Light Objects or entries in data. 

Light Index The index of the light within the data entry to change to. 

Fade Node 

A node that controls when to fade in and out of your cutscene. 

Fade Element 

An element that specifies when and how to fade your cutscene. 

Amount  - Faded The opacity level when the fade element is fully faded. 

Amount – Unfaded The opacity level when the fade element is fully unfaded. 

Color The color of the fade. 

Fade In When true, specifies the fade element goes from Faded to Unfaded.  
When false, specifies the fade element goes from Unfaded to Faded. 



Bookmark Node 

A node containing a list of bookmarks. 

Bookmark Element 

A generic time event that can be referenced by other systems. 

Bookmark Name The name of this bookmark.  Naming a bookmark allows you to 
reference it elsewhere. 

Jump to Bookmark When Hit Allows you to specify a bookmark to jump to when this bookmark is 
passed.  Useful when you want your cutscene to loop. 

Pause When Hit When enabled, the cutscene will automatically pause when this 
bookmark is hit. 

Path Node 

A path object in your scene.  The path is defined by a series of Path Marker Nodes 

Path Marker Node 

A single point in a path. 

In Tangent Type The curve type when curving into this path marker.  Legal values are 
Fast, Flat, Linear, Slow, Smooth, Step, and Auto. 

Out Tangent Type The curve type when curving out of this path marker.  Legal values are 
Fast, Flat, Linear, Slow, Smooth, Step, and Auto. 

Light 

An object that emits light in your scene.  It can be either a Spot Light or Omni Light. 

Ambient Occlusion When enabled, this light contributes to Ambient Occlusion. 

Attenuation Far The distance at which the light is fully faded out. 

Attenuation Near The distance at which the light begins to fade out. 

Color The color of the light. 

Color Multiplier The intensity of the light. 

Eye Position The position of the “eye” or source of the light. 

Falloff (Spot) The distance at which the spotlight is fully dimmed. 

Hotspot (Spot) The radius of the bright glowing center of a spotlight. 

Light Opaque Objects When enabled, this light affects opaque objects. 

Light Transparent Obects When enabled, this light affects transparent objects.  Transparent 
lighting is expensive, so use sparingly. 

Minimum Light Level The minimum graphics option level at which this light appears.  Legal 
values are None, Low, Medium, High, Ultra. 

Shadow Casting When enabled, this light casts shadows. 

Specular When enabled, this light contributes to specular lighting.  Specular 
lighting is the bright points you see on shiny materials. 

Specular Color The color of specular highlights this light creates. 

Target Position (Spot Only) The target position of the spot light. 

Fog 

An object that controls the fog of your scene. 



Color The color of the fog 

Density The thickness of the fog 

Falloff The distance at which fog blends from invisible to fully visible 

Start Height The height at which fog begins 

Text 

An object that draws text in the world. 

Color The color of the text 

Text The text value.  Any valid text tags are legal here.  You can also specify 
the value “(frame)” or “(time)” to substitute the current frame or time 
for the text. 

RTT Node 

An object that controls “Render to Texture”.   

RTT Channel The channel this RTT object renders to. 

RTT Element 

An element that defines when a specific camera should render to a texture. 

Aspect Ratio The aspect ratio of the texture to be rendered to. 

Camera Index The camera index of the camera to render onto the texture 

Object GUID The GUID of the camera object rendering onto the texture. 

Conversation Driver Node 

Conversation Link The conversation data entry associated with this driver node. 

Conversation Driver Element 

Alternate Line ID An alternate Line ID this driver element is legal for. 

End Buffer Time The amount of time before the end of this driver line where we send the 
synchronous message saying the line is complete.  Increase this value if 
you are experiencing issues in multiplayer games where your lines bleed 
into each other. 

Line ID The Line ID that this conversation driver element controls. 

 

 


